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Background 
The purpose of this document is to assist individuals in creating, testing, and remediating 
Microsoft Excel Spreadsheets, for Section 508 conformance. The guidance provided is based 
on the Section 508 Baseline Test Guide for Excel files, and the Section 508 Microsoft Excel 
2016 Checklist authored by the Accessible Electronic Document Community of Practice (AED 
COP). For more information on the AED COP, to download the latest AED COP guidance, and 
to gain access to a detailed test process, visit the Federal Section 508 website. 

How to Read This Document 
This document is comprised of two sections:  

1. The AED COP Microsoft Excel 2016 Checklist. 
2. Instructions on how to remediate Excel files for Section 508 compliance.  

For more information on how to remediate MS Excel (.xlsx) documents or to request training, 
please contact your agency Section 508 Coordinator or email Section508-OCIO@usda.gov.   
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AED COP Excel Checklist 
When creating an accessible spreadsheet, or when reviewing an Excel file for Section 508 
conformance, the following conditions must be considered. The response to each criterion should 
be Yes or Not Applicable to be considered accessible. If No is selected, the issue must be 
resolved to be considered accessible.  

For ease of use, Microsoft Excel’s Accessibility Checker is located on Microsoft’s main menu 
under File > Info > Check for Issues > Check Accessibility.  

Note: Due to the human-centric nature of accessibility and Section 508 conformance, content 
creators must ensure individuals with disabilities are able to request additional formats and 
corrections that may not be detected using automated tools, i.e., improper use of color coding. 

Document Formatting 
 Yes No NA 

The filename is descriptive and identifies the document or its purpose.    
The file type is an Excel 2016 Workbook (.xlsx).    

 

 Yes No NA 
The reading order matches the visual layout on each spreadsheet.    

 

Text Formatting 
 Yes No NA 

Link names are unambiguous within context and describe the 
destination, function, or purpose. 

   

 

Object Formatting 
 Yes No NA 

Vital information is duplicated at or near the start of the related 
information. 

   

 

 Yes No NA 
Data tables are not pictures.    
Data tables do not have merged/split cells.    
Data tables do not have more than one header row/column.    

 

 Yes No NA 
There is descriptive alternate text, descriptive text in surrounding text, 
or in an appendix. 
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Color Formatting 
 Yes No NA 

Text duplicates the meaning of the color or other sensory 
characteristics. 

   

 

 Yes No NA 
The color contrast ratio passes (WCAG Level AA).    

 

Miscellaneous 
 Yes No NA 

For audio-only, the transcript is accurate and complete.    
For video-only, the text description is accurate and complete.    
For multimedia, the synchronized captions and audio description are 
accurate and complete. 

   

 

 Yes No NA 
Forms are not enabled.    

 

 Yes No NA 
Flashing objects are excluded.    

 

 Yes No NA 
The information is equivalent and up to date with the primary 
document. 
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Microsoft Excel 2016 | Basic Authoring and Testing Guide 
This section provides detailed instructions on creating, remediating, and testing MS Excel files 
(.xlsx) for accessibility. 

Document Formatting 
1. Is the filename descriptive and is the file in .xlsx format? 

How to Test 

Instruction: Look at the filename in Windows Explorer or the title bar in MS Excel. An 
example of a descriptive filename is “FundingBudget.xlsx.” The file must be in the “*.xlsx” 
format for accessibility testing to be possible. 

NOTE: If the document extension is not displayed, open your documents folder in 
Windows Explorer, select “View”>check “File name extensions.” 

Figure 1: The Save As dialog window 

 

Test A: Is the file name descriptive and does it identify the document or its purpose? If not, 
the document fails this test. 

Test B: Is the file in “Excel Workbook (.xlsx)” format? If not, the document fails this test. 

How to author for accessibility 

A descriptive file name identifying the document, or its purpose, helps everyone (including 
people with disabilities) locate, open, and switch between documents. In addition, the 
document must be in a “.xlsx” format because these authoring and testing instructions will 
only work if the file is in the “.xlsx” file format. 

• Select “File tab>Save As” 

• Save as type: “Excel Workbook (*.xlsx)” with a descriptive filename. 



 

Content written and managed by the AED COP | Last Updated: August 2021 
7  

Text Formatting 
2. Are built-in features used to organize content? 

How to test 

Test A: Does each sheet have a visual and/or logical reading order, left to right then top to 
bottom? If not, it fails this test. 

Test B: Can the sheet be navigated using the up, down, right or left arrow keys, and does it 
match the visual/logical reading order? If not, it fails this test. 

How to author for accessibility 

To create a worksheet with logical reading order content: 

• Start all worksheets in cell A1 
• Do not span content over multiple rows or columns. 

Figure 2: Example of Excel Worksheet with logical reading order 

 

3. Are link names descriptive? 
How to test 

Instruction: Find hyperlinks within a worksheet 

Test: Do links have meaningful names that describe their destination, function, and/or 
purpose OR are these determinable within context? If not, the document fails this test. 

Uniquely Named Link: 
 www.section508.gov 
Link Determinable within context: 
 Get My Section 508 Questions Answered 
An unclear link name with no context: 
 click here 
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How to author for accessibility 

Assistive technology users rely on meaningful names to determine the destination, function, 
or purpose of links. For example, multiple “click here” links are confusing to assistive 
technology users because the name for each link is the same, while the destinations may be 
different. 

Figure 3: Insert Hyperlink configuration window 

 

Naming and creating links: 

• To edit the name of a link, select the cell containing the hyperlink. Edit the text in 
the Formula Bar.  

• To create a hyperlink, select the cell for the hyperlink and either use the Hyperlink 
button on the "Insert" ribbon menu or “Ctrl+K” to open the Insert Hyperlink 
configuration window. Specify the Text to display and the Address for the link and 
its destination. 
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Object Formatting 
4. Is vital information in headers, footers, and watermarks duplicated in the 

worksheet? 
How to test 

Instruction: Look for vital information in headers, footers, and watermarks (e.g. Respond 
by X date, CONFIDENTIAL, or Do Not Distribute). Note: Watermarks in Excel are 
floating objects, and cannot be made accessible. 

Test: Is the vital information duplicated in the first cell of the worksheet? If not, the 
document fails this test. 

Figure 4: Example of vital information repeated in cell A1 of the worksheet 

 

How to author for accessibility 

Assistive technology does not automatically read information in headers, footers, and 
watermarks, so you need to duplicate any vital information in cell A1. 
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5. Did you use built-in features to create data tables? 
How to test 

Instruction 1: Select a table (“Home>Editing>Find & Select>Go To”). Select any table 
listed in the “Go To” options window. Note: Images of tables will never be listed in the “Go 
To” options window. 

Test A: Does a “Table Name” display under the “Table Tools>Design>Properties” group? 
If not, the document fails this test 

Figure 5: Table Properties group displaying Table Name 

 
Instruction 2: Place your cursor on the first row and/or column of a table cell and see if the 
worksheet has identified the header row and/or column. 

Test B: Are “Header Row” and/or “First Column” in the “Table Style Options” group 
checked? If not, the document fails this test.  
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Figure 6: Header Row and First Column checked in the Table Style Options group 

 
Instruction 3: Select a table. If the Ribbon shows “Picture Tools” tab, instead of the “Table 
Tools” tab, then the table is an image. 

Test C: Is the worksheet free of pictures of tables? If not, the document fails this test. 

Figure 7: Image of data table showing “Picture Tools>Format” tab when selected 

 

How to author for accessibility 

Assistive technology users need to be able to identify column headers in data tables to 
understand the association between table cells and their respective headers. 
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To create an accessible data table you Select “Insert>Table.” 

1. In the create table pane, choose the range of cells for your data table. 

2. Check the “My table has headers” checkbox in the create table pane. 

3. Choose any cell and name your table “Table Tools>Design>Table Name.” 

4. Choose the first cell in the header column and/or row, and update the column and/or row 
headings with descriptive names. 

How to test 

Figure 8: Image of data table showing “Picture Tools>Format” tab when selected 

 

6. Do images and other objects have alternative text 
How to test 

Instruction 1: Examine cells surrounding a non-text element for text describing the object 
or its purpose/meaning.  

Test A: Does the image/object/shape/chart or other non-text element have descriptive text 
or is there an appendix for all non-text elements? If not, the document fails this test. 

How to author for accessibility 

In Excel images, objects, shapes, charts and other non-text elements cannot be 
anchored/embedded in a cell. Screen reader users cannot access the alt-text of floating 
elements. Therefore, you must add descriptive text to images and other objects by adding 
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information in a cell near the object or list the non-text elements and their descriptions in a 
separate appendix.  
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Color Formatting 
7. Are colors and other visual characteristics that convey information (such as 

size, shape, and location) also described in text? 
How to test 

Using only color or other visual characteristics to convey meaning will not provide 
comparable access to people who are blind, have low vision, or are colorblind. 

Instruction: Find where you have used color and/or other visual characteristics to convey 
meaning such as green, yellow, red, etc. 

Test: Is there text that conveys the meaning of the color or other visual characteristics? If 
not, the document fails this test. 

How to author for accessibility 

The following layout tables describe the progress for three projects using colors to 
symbolize the current project status. Adding text in addition to the color provides 
comparable information to users of assistive technology and people who are colorblind. 

Use text to duplicate the meaning of the color or visual characteristics (such as size, shape, 
and location). 

Table 1: Examples of a project status table using only color and color with text 

Project Status 

Project A  

Project B  

Project C  

 

  

Project Status 

Project A On Time 

Project B At Risk 

Project C Late 
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8. Is the contrast ratio between text and background sufficient? 
NOTE: If the document text is black on white background (or close to it), you do not need 
to perform this test. This test requires the Colour Contrast Analyzer (an external 
application). 

How to test 

Execute the Colour Contrast Analyzer. Select “Download” (the application can be executed 
without downloading it onto your computer). Open the Colour Contrast Analyzer. Drag the 
“Foreground eyedropper” icon over a sample of your text or image of text. Drag the 
“Background eyedropper” icon over a sample of your background color. 

Test: Have you formatted with the correct color contrast ratio? If not, the document fails 
this test. 

Figure 9: Examples of pass and fail results with the Colour Contrast Analyzer 
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How to author for accessibility 

People who are colorblind or have low vision will have comparable access if there is 
sufficient contrast between the text and the background. The contrast standards are: 

Table 2: Table with contrast ratios for types and sizes of text 

Type or Size of Text Contrast Ratio 

Standard text (12 pt regular) 4.5:1 

Large Text (14 pt bold or 18 pt regular) 3:1 

Incidental text, text overlaid on images, and logotypes Excluded from requirement 
 

Create content with text or images of text that use color or shading with sufficient color 
contrast. If the contrast ratio does not pass, then adjust your foreground or background until 
it does pass. 

Table 3: Examples of good and insufficient color contrast ratios 

Good Color Contrast Insufficient Color Contrast 

White text on  
black background  
ratio 21:0:1 

Dark gray text on  
black background 
ratio 3.0:1 

Dark green text  
on yellow background 
ratio 7.6:1 

Orange text on  
yellow background 
ratio: 2.1:1 

Light blue text on  
dark blue background 
ratio: 10.5:1 

Red text on  
dark blue background 
ratio: 1.1:1 

white text on  
red background 
ratio: 6.5:1 

Dark green text on  
red background  
ratio: 1.3:1 
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Miscellaneous 
9. Are descriptions of embedded audio, video and multimedia files accurate? 

How to test 

NOTE: If the document does not contain audio, video, or multimedia files, you do not need 
to perform this test. 

Instruction: Activate the audio-only, video-only, or multimedia file. 

Test A: Is there an accurate and complete text transcript for multimedia files, text 
description for audio files, and synchronized caption and/or audio description for video 
files? If not, the document fails this test. 

How to author for accessibility 

If you embed an audio-only, video-only, or multimedia file that contains meaningful 
information into your MS Excel Workbook, you must also provide additional information so 
that individuals with disabilities have comparable access to the information. 

• Audio-only 
o Accurate and complete transcript 

• Video-only 
o Accurate and complete text description 

• Multimedia (audio and video) 
o Accurate and complete synchronized captions and audio descriptions 

10. Did you exclude flashing objects? 
How to test 

Test: Is the document free of all flashing objects? If not, the document fails this test. 

How to author for accessibility 

Create your content without using flashing objects. Flashing objects can cause seizures and 
should never be used. 
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