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Background 
The purpose of this document is to assist individuals in creating, testing, and remediating PowerPoint 
presentations, for Section 508 conformance. The guidance provided is based on the Section 508 
Baseline Test Guide for PowerPoint, and the Section 508 PowerPoint Checklist authored by the 
Accessible Electronic Document Community of Practice (AED COP). For more information on the 
AED COP, to download the latest AED COP guidance, and to gain access to a detailed test process, 
visit the Federal Section 508 website. 

How to Read This Document 
This document is comprised of two sections:  

1. The AED COP PowerPoint Checklist. 
2. Instructions on how to remediate PowerPoint presentations for Section 508 compliance.  

For more information on how to remediate PowerPoint presentations or to request training, please 
contact your agency Section 508 Coordinator or email Section508-OCIO@usda.gov.   
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AED COP PowerPoint Checklist 
When creating an accessible PowerPoint presentation, or when reviewing a PowerPoint presentation 
for Section 508 conformance, the following conditions must be considered. The response to each 
criterion should be Yes or Not Applicable to be considered accessible. If No is selected, the issue must 
be resolved to be considered accessible.  

For ease of use, Microsoft’s Accessibility Checker is located on Microsoft’s main menu under File > 
Info > Check for Issues > Check Accessibility.  

Note: Due to the human-centric nature of accessibility and Section 508 conformance, content creators 
must ensure individuals with disabilities are able to request additional formats and corrections that may 
not be detected using automated tools, i.e., improper use of color coding. 

Document Formatting 
 Yes No NA 

The filename is descriptive and identifies the document or its purpose.    
The file type is in a PowerPoint presentation (.pptx) format.    

 

Text Formatting 
 Yes No NA 

Objects match the visual reading order on each slide.    
 

 Yes No NA 
One of the built-in list features (i.e., Bullets or Numbering) is used to 
create lists. 

   

 

 Yes No NA 
The correct number of columns are highlighted.    

 

 Yes No NA 
The text language matches the PowerPoint Presentation’s proofing 
language. 

   

 

 Yes No NA 
Link names are meaningful and descriptive of the destination, function, 
or purpose. 
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Object Formatting 
 Yes No NA 

Vital information in the Selection pane can be selected.    
 

 Yes No NA 
Data tables are not pictures.    
Data tables do not have merged/split cells.    

 

 Yes No NA 
Images, objects, and shapes have descriptive text as alternative text, or 
in surrounding text. 

   

Decorative images or objects have at least one space between quotation 
marks to allow assistive technology to bypass the image or object (i.e., 
“ “). 

   

 

 Yes No NA 
All flashing objects are excluded in the document.    

 

Color Formatting 
 Yes No NA 

Text duplicates the meaning of the color or other sensory 
characteristics. 

   

 

 Yes No NA 

The color contrast ration passes WCAG Level AA.    
 

Multimedia 
 Yes No NA 

For audio-only, the transcript is accurate and complete.    
For video-only, the text description is accurate and complete.    
For multimedia, the synchronized captions and audio description are 
accurate and complete. 
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Testing Presentations for Accessibility 
This section provides detailed guidance on how to make MS PowerPoint presentations accessible. 

Document Formatting Instructions 
The filename must be clear, concise, and descriptive, and the file must be saved in the .pptx format. 
The filename should identify the document and its purpose in order to assist others in locating the 
correct file.  

 

Figure 1: Descriptive Filenames 
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Reading Order Instructions 
The order in which assistive technology reads each slide must match the visual layout. To ensure the 
proper reading order: 

1. Open the Selection Pane by navigating to the Home tab and selecting Drawing > Arrange > 
Selection Pane. 

2. The first object on the slide will be displayed at the bottom of the Selection Pane. Starting 
from the bottom, select each object to view the reading order on the slide.  

3. If the order of selection list does not match the visual layout, manually reorder the list until it 
matches the visual layout. 

 

Figure 2: Selection Pane 
Note: The order in which objects are added to the page typically determines the order they will appear 
in the Selection Pane. Remember to start from the bottom of the list to determine the proper order. 
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List Formatting Instructions 
Lists must be created using the standard options provided in the Bullet and Numbering System found 
in the Home tab under the Paragraph section. Unordered lists must be created using the Bullet 
Library, while ordered lists must be created using the Numbering Library.  

 

Figure 3: Bullet and Numbering System 
Note: Avoid using custom images for Bullets (i.e., arrows, diamonds, custom icons, etc.). When 
converting to PDF, lists with custom Bullets are misinterpreted as plain text next to an image. 
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Column Formatting Instructions 
Columnar text must be formatted using the Add or Remove Columns option, which can be found on 
the Home tab in the Paragraph section. The number of columns in this view must match the number 
of columns visually on the slide. 

 

Figure 4: Column Formatting Window 
Select Home tab > Paragraph > Add or Remove Columns and choose the preferred number of 
columns when creating columnar text. 
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Language Formatting Instructions 
Note: If the document only uses one language, you do not have to perform this test. 

If the presentation contains words or phrases in a language other than the predominant language, 
complete the following steps:  

1. Place your cursor on the text.  
2. In the Review tab, navigate to Language Group > Language Button > Set Proofing 

Language. 
3. Select the appropriate language for the text. 

 

Figure 5: Setting Proofing Languages 

All text must be formatted in its respective language to ensure accessibility. 
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Link Description Instructions 
All hyperlinks throughout the presentation must have clear, concise, and meaningful descriptions that 
describe their destination, function, and/or purpose OR this information is discernable within context. 

• Example of a Uniquely Named Link: www.section508.gov 
• Example of a link description Discernable Within Context: Get My Section 508 Questions 

Answered 
• Example of an unclear link description without context: click here 

To create a hyperlink: 

1. Select the descriptive text, right click, and select “Hyperlink” OR use “Ctrl + K” to open the 
Insert Hyperlink configuration window. 

2. Verify that the descriptive text matches the information in the Text to Display field. 
3. Enter or paste the URL into the Address field and select OK. 

 

Figure 6: Hyperlinks 
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Object Formatting Instructions 
Headers and Footers 
Vital information in headers, footers, and watermarks must also be included the correct reading order 
in the Selection Pane. The Selection Pane can be found on the Home tab under Drawing > Arrange 
> Selection Pane. 

 

Figure 7: Headers and Footers 
Note: The reading order is determined from the bottom up in the Selection Pane. 

Headers and Footers must be enabled for the information to be found in the Selection Pane. To enable 
Headers and Footers in the presentation: 

1. On the Insert tab, navigate to Text > Header & Footer. 
2. Check the “Footer” option. 
3. Enter the information and select “Apply.” 
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Data Tables 
To create an accessible data table, navigate to the Insert tab, select Table Group > Insert Table, and 
select the number of rows and columns.  

 

Figure 8: Creating Tables 
Note: Complex data tables with merged/split cells or multiple header rows/columns cannot be made 
accessible in MS PowerPoint. The presentation must be converted into PDF and the table remediated 
in Adobe Pro DC.  

To evaluate data tables for accessibility: 

1. Tables must be created using built-in features and cannot be an image. To determine if a table 
on a slide is an image, select the table and check tab appears in the Ribbon. If the “Picture 
Tools” tab appears, the table is an image. If the “Table Tools” tab appears, continue to the next 
step. 
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Figure 9: Properly Formatted Table Example 
2. Ensure that the table does not have merged or split cells. Select the table and use your Tab Key 

to move between each data cell and determine if a cell spans multiple rows or columns. 
Example of an accessible data table: 
 

 

Figure 10: Accessible Table Example 
  



 

Content written and managed by the AED COP | Last Updated: July 2021                        14 
  

Alternative Text 
Alternative text is a concise description detailing the purpose of images and similar objects.  Without 
alternative text, users that are unable see the images in the document will not be able to access all the 
information provided in the document.  

Right click an image or object and select Format Picture/Object/Shape. Select the Size and 
Properties icon and enter alternative text in the Description box.  

 

Figure 11: Alternative Text for Images 
If the image is decorator and can be skipped by assistive technology, enter two spaces between 
quotation marks (i.e., “  “) in the Description box. 

  



 

Content written and managed by the AED COP | Last Updated: July 2021                        15 
  

Color Formatting Instructions 
Visual Cues and Color Coding 
The use of color cannot be the sole method to convey significance or meaning. To provide comparable 
access to people who are blind/colorblind or have low vision, a combination of visual and non-visual 
characteristics should be used.  

Example: The following layout tables describe the progress for three projects using colors to symbolize 
the current project status. The first table fully relies on color, while the second uses a combination of 
color and text to convey meaning: 

Table 1: Improper Use of Color 

Project Status 

Project A  

Project B  

Project C  

 
Table 2: Proper Use of Color 

 

 

  

Project Status 

Project A On Time 

Project B At Risk 

Project C Late 
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Color Contrast 
Note: This test requires the use of an external application called Colour Contrast Analyzer that can 
be executed without downloading. If using the default settings (white background and black text), skip 
this test.  

The visual presentation of text and images that contain text must have a minimum contrast level of 
4.5:1 for regular text and 3:1 for large text -- over 18pt not bolded, over 14pt if bold -- to meet the 
WCAG Level AA requirement.  

Run the Colour Contrast Analyzer and drag the Foreground Eyedropper tool over a sample of the 
text color. Repeat this step using the Background Eyedropper tool and a sample of the background 
color. If the contrast ratio is greater than 4.5:1 for regular text and 3:1 for large text, the color contrast 
is sufficient. 

Figure 12: Colour Contrast Analyzer with Passing Score 
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Figure 13: Colour Contrast Analyzer with Failing Score 

 

Note: Incidental text, text overlaid on images, and logotypes are exempt.  

The table below provides examples of accessible and inaccessible color contrast ratios:  

Accessible Color Contrast Inaccessible Color Contrast 

White text on  
black background  
ratio 21.0:1 

Dark gray text on  
black background 
ratio 3.0:1 

Dark green text  
on yellow background 
ratio 7.6:1 

Orange text on  
yellow background 
ratio: 2.1:1 

Light blue text on  
dark blue background 
ratio: 10.5:1 

Red text on  
dark blue background 
ratio: 1.1:1 

white text on  
red background 
ratio: 6.5:1 

Dark green text on  
red background  
ratio: 1.3:1 

Table 3: Contrast Examples 
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Multimedia Instructions 
Descriptions of embedded audio, video, and multimedia files must be provided to ensure individuals 
with disabilities have comparable access to the information. The descriptions must be tested for 
accuracy and completeness.  

Type of Media Description Requirement 
Audio-Only Transcript 
Video-Only Text Description 
Multimedia (audio and video) Synchronized captions and audio descriptions 
Flashing Objects Do not use flashing objects. 
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