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Background 
The purpose of this document is to assist individuals in creating, testing, and remediating MS 
Word Documents, for Section 508 conformance. The guidance provided is based on the Section 
508 Baseline Test Guide for Word Documents, and the Section 508 Word Document Checklist 
authored by the Accessible Electronic Document Community of Practice (AED COP). For more 
information on the AED COP, to download the latest AED COP guidance, and to gain access to 
a detailed test process, visit the Federal Section 508 website. 

How to Read This Document 
This document is comprised of two sections:  

1. The AED COP Word Document Checklist. 

2. Instructions on how to remediate Word documents for Section 508 compliance.  

For more information on how to remediate Emails or to request training, please contact your 
agency Section 508 Coordinator or email Section508-OCIO@usda.gov.   
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AED COP Word Document Checklist 
When creating an accessible Word Document, the following conditions must be considered. 
The response to each criterion should be Yes or Not Applicable to be considered accessible. If 
No is selected, the issue must be resolved to be considered accessible.  

For ease of use, Microsoft’s Accessibility Checker is located on Microsoft’s main menu under 
File > Info > Check for Issues > Check Accessibility.  

Note: Due to the human-centric nature of accessibility and Section 508 conformance, content 
creators must ensure individuals with disabilities are able to request additional formats and 
corrections that may not be detected using automated tools, i.e., improper use of color coding. 

General 
 Yes No NA 

The file type is Word document (.docx) format.    
The filename identifies the document or its purpose.    

 

Headings 
 Yes No NA 

Headings in the “Navigation” pane mirror the headings in the 
document. 

   

Headings in the “Navigation” pane match the document’s visual 
outline. 

   

 

Lists 
 Yes No NA 

The “List” option is visible under “Bullets and Numbering.”    
 

Columns 
 Yes No NA 

“COLUMNS:” shows under “Section” in columnar text options.    
 

Layout Tables 
 Yes No NA 

Layout tables’ tab order match the visual layout.    
“Text Wrapping” is set to “None” in Table Properties.    
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Language 
 Yes No NA 

Languages are correctly formatted in the document.    
 

Links 
 Yes No NA 

Link names describe destination, purpose, or context.    
Links have unique names.    

 

Headers, Footers, and Watermarks 
 Yes No NA 

Vital information in headers, footers, and watermarks is also shown in 
the content. 

   

 

Data Tables 
 Yes No NA 

Tables are not pictures.    
Tables are free of merged or split cells.    
Tables repeat their header row.    
Table Properties > “Text Wrapping” is set to “None.”    

 

Images and Other Objects 
 Yes No NA 

Images/objects have Alt Text or are described in context.    
Decorative images use spaces between quotes as Alt Text (“  “).    
Accessibility Checker does not report “Objects not inline for 
meaningful images.” 

   

 

Text Boxes 
 Yes No NA 

Text boxes do not have any “Objects not in-line” warnings.    
 

Colors and Sensory Characteristics 
 Yes No NA 

Meaning of color or other sensory characteristics is duplicated in text.    
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Color Contrast 
 Yes No NA 

Text and Large Text (including images of text) pass the Colour 
Contrast Analyzer. 

   

 

Audio, Video, and Synchronized Media 
 Yes No NA 

Audio-only content has an accurate and complete transcript.    
Video-only content has an accurate and complete description.    
Synchronized media has accurate and complete synchronized captions.    
Synchronized media has accurate and complete synchronized audio 
descriptions. 

   

 

Forms 
 Yes No NA 

Fillable form fields are excluded from the document.    
 

Flashing Objects 
 Yes No NA 

Flashing objects are excluded from the document.    
 

Alternative Accessible Version 
 Yes No NA 

Alternate versions are equivalent and up to date.    
 

Notes 
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Formatting for Word Documents 
This section details best practices to follow in addition to the checklist to ensure accessibility. 

Document Formatting 
The file must be in .docx format, unprotected, and have a descriptive filename. 

Example of non-descriptive filename: Document1.docx 

Example of a descriptive filename: USDA Section 508 Reference Manual.docx 

If the filename extension is not displayed, open your documents folder in Windows Explorer, 
select “View” and enable the checkmark for “File name extensions.” 

Figure 1: "Save As" Options Window. 

 

To determine whether the file is protected, select the Review tab > Restrict Editing and check 
if the Stop Protection button appears at the bottom of the Restrict Editing pane. If the Restrict 
Editing pane shows options 1, 2, and 3, then restricted editing is successfully turned off.  
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Figure 2: Restrict Editing pane options and protected enabled views. 

 

Note: Document protections limit the ability to test for accessibility and can make part or all the 
document inaccessible. 
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Text Formatting 
Heading Styles 
The MS Word heading styles should be used throughout the document where applicable and in 
the correct hierarchy. To determine if heading styles were used, open the Navigation pane (Ctrl 
+ F) and select the Headings tab. All heading styles used in the document will be listed in 
chronological order.  

Figure 3: Matching headings displayed in Navigation Pane and document. 

 

Figure 4: Styles Pane and options window with Heading 1 Style selected 
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Lists 
Lists used to organize or structure content must be created using the built-in features found in the 
Bullets and Numbering pane on the Home tab > Paragraph pane.  

Figure 5: Paragraph tab displaying options for bulleted, numbered, and multilevel lists. 

 

To ensure the appropriate hierarchy is used in a list, place your cursor on a list and open the 
Reveal Formatting pane.  

Figure 6: List option displayed under Bullets and Numbering. 
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Columnar Content 
Any content that visually appears to be formatted in columns (like newspaper articles), open the 
Reveal Formatting pane (Shift + F1), and select the arrow sign to expand “Section.” Under the 
Columns option, ensure the correct number of columns is listed. 

Figure 7: Number of columns displayed under Section > Columns 

 

Navigate to the Layout tab > Page Setup > Columns when creating columns in your document. 
Select the content to be formatted, then Columns, and the number of columns.  

Figure 8: Columns menu set to Two Columns option. 
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Layout Tables 
Layout tables arrange content on the page.  

Instruction 1: Place your cursor on the first cell of your layout table. Use the Tab Key to 
navigate through the table. If the tab order does not match the visual layout, the document fails 
this test.  

Instruction 2: “Right Click” (Shift + F10) inside a layout table and select Table Properties > 
Text Wrapping. “None” should be selected, else the document fails this test. 

Figure 9: Table Properties Table tab displaying Text Wrapping set to "None." 
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Languages 
Note: Documents that only use one language do not need to be tested.  

If the document contains words/phrases in a language other than the predominant language, place 
your cursor on the text and open the Reveal Formatting pane (Shift + F1) > Language and 
ensure the correct language is applied. 

Figure 10: Korean language displayed under Font > Language formatting option. 

 

To set a different language, select Set Proofing Language in the same pane, and select the 
appropriate language from the list. 
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Descriptive Links 
Links must have meaningful names that describe their destination, function, and/or purpose OR 
the name must be easily determinable within context.  

Example of a uniquely named link: https://www.section508.gov/ 

Example of a link whose name is determinable within context: Get My Section 508 Questions 
Answered 

Example of an unclear link name without context: click here 

To edit the name of a link, right click the link and select Hyperlink. In the “Text to display” 
field, ensure the appropriate name is entered. Additionally, in the “Address” field, ensure the 
appropriate URL is displayed. Select OK. 

Figure 11: Insert Hyperlink configuration window. 
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Object Formatting 
Headers, Footers, and Watermarks 
Assistive technology does not automatically read information in headers, footers, and 
watermarks. 

Vital information found in headers, footers, and watermarks must be duplicated within the body 
of the document near the beginning (e.g., Respond by X date, Confidential, or Do Not 
Distribute).  

Figure 12: Example of vital information in a header repeated in the body of the document. 
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Data Tables 
Data tables must be created using the built-in table feature and cannot be an image. To determine 
if a table is an image, select the table and check if the Picture Tools tab appears in the Ribbon. If 
the Table Tools tab appears instead, the document passes this test. 

Additionally, data tables cannot contain merged/split cells. Select the table and navigate to the 
Table Tools tab. Under the Layout tab, select Table Group > View Gridlines button and 
search for table cells that are merged or split. 

Figure 13: Complex table with merged and split cells. 

 

Next, header rows must be identified and repeated across page breaks. Select any cell in the 
header row, open the Reveal Formatting pane (Shift + F1), and look under Table. If the header 
row is not set, the option to repeat the header across page breaks will not be available. Identify 
the header row and make sure the “Repeat as header row” option is checked. 

Figure 14: Table properties with Repeat Header Row setting selected. 
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Lastly, under Table Properties > Table tab > Text Wrapping, ensure the “Text Wrapping” 
option is set to None. 

Figure 15: Table Properties window with Text wrapping set to "None." 

 

Note: Complex data tables that require multiple header rows, a header column, and/or 
merged/split cells require the document to be converted into an accessible format (i.e., an PDF 
document remediated for accessibility). Complex data tables cannot be made accessible in 
MS Word. 
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Alternative Text 
Meaningful images, objects, and shapes are required to have descriptive text detailing all vital 
information. This can be achieved either by using alt text, captions, or by describing the image in 
the surrounding text.  

To enter/edit alt text for an image/object/shape: 

1) Right click (Shift + F10) the image and select Format Picture/Object/Shape. 

2) Navigate to the Layout & Properties icon and select “Alt Text” 

3) In the Description field, enter the descriptive text. 

4) If the image is meant to be decorative, enter at least two blank spaces between quotation 

marks in the Description field.  

Figure 16: Format Picture -- Alt Text Options 
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Inline Objects 
Images, objects, and text boxes must be configured to be “inline with text.” To determine if any 
images throw an “object not inline” warning, run the Accessibility Checker by following these 
steps:  

1) On the File tab, under Info, select Check for Issues > Check Accessibility 

2) If any “object not inline” warnings appear, continue to the next step. 

3) Select the image, object, or text box. 

4) Select Picture/Object/Shape Tools > Format > Position > In Line with Text. 

Figure 17: Format tab Position menu option with "in line with text" selected. 
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Color Formatting 
Visual Cues and Color Coding 
The use of color cannot be the sole method to convey significance or meaning. To provide 
comparable access to people who are blind/colorblind or have low vision, a combination of 
visual and non-visual characteristics should be used.  

Example: The following layout tables describe the progress for three projects using colors to 
symbolize the current project status. The first table fully relies on color, while the second uses a 
combination of color and text to convey meaning: 

Table 1: Improper Use of Color 

Project Status 

Project A  

Project B  

Project C  

 

Table 2: Proper Use of Color 

 

 

 

  

Project Status 

Project A On Time 

Project B At Risk 

Project C Late 
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Color Contrast 
Note: Documents where the text/background are black/white do not need to perform this test. 
This test requires the use of the Colour Contrast Analyzer (an external application).  

Execute the Colour Contrast Analyzer and select “Download.” Open the application, drag the 
foreground eyedropper icon over a sample of text, and drag the background eyedropper icon over 
a sample of the background. The required color contrast ratio for standard text is 4.5:1, and 3:1 
for large text. Incidental text, text overlaid on images, and logotypes are excluded from this 
requirement.  

Figure 18: Example of passing results with the Colour Contrast Analyzer. 
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Table 3: Examples of good and insufficient color contrast ratios. 

Good Color Contrast Insufficient Color Contrast 

White text on black 
background 

ratio 21:0:1 

Dark gray text on black 
background 

ratio 3.0:1 
Dark green text on yellow 
background 

ratio 7.6:1 

Orange text on yellow 
background 

ratio: 2.1:1 
Light blue text on dark blue 
background 

ratio: 10.5:1 

Red text on dark blue 
background 

ratio: 1.1:1 

white text on red background 

ratio: 6.5:1 

Dark green text on red 
background 

ratio: 1.3:1 
 

Miscellaneous 
Transcripts, Text Descriptions, and Synchronized Captions 
Documents that contain audio, video, or multimedia files must have accurate and complete 
alternate methods of interpreting the information. 

Multimedia files require a text transcript, audio files require text descriptions, and video files 
require synchronized captions and/or audio descriptions. 

Forms 
Interactive form fields created from built-in form features are used to collect data, however they 
cannot be made accessible. Ensure that the document is free of all MS Word form fields. This 
does not include blank table fields/spaces that users fill in with text. 

Flashing Objects 
Flashing objects can cause seizures and should never be used. Ensure the document is free of all 
flashing objects. 
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